Page MenuHomeThat World

Fix all dpt and rplx dependencies to use libsecp256k1
ClosedPublic

Authored by sorpaas on Feb 5 2018, 11:59 AM.

Details

Summary

Switch everything to use libsecp256k1 and remove all secp256k1-plus dependency.

Diff Detail

Repository
rDEVPTP devp2p-rs
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

sorpaas created this revision.Feb 5 2018, 11:59 AM

Build has FAILED

Link to build: https://jenkins.that.world/job/devp2p-rs/1/
See console output for more information: https://jenkins.that.world/job/devp2p-rs/1/console

sorpaas updated this revision to Diff 95.Feb 5 2018, 12:43 PM
  • Add Nix support

Build has FAILED

Link to build: https://jenkins.that.world/job/devp2p-rs/2/
See console output for more information: https://jenkins.that.world/job/devp2p-rs/2/console

sorpaas updated this revision to Diff 96.Feb 5 2018, 12:50 PM
  • Fix tests

Build has FAILED

Link to build: https://jenkins.that.world/job/devp2p-rs/3/
See console output for more information: https://jenkins.that.world/job/devp2p-rs/3/console

sorpaas updated this revision to Diff 97.Feb 5 2018, 12:56 PM
  • Fix submodule tests
sorpaas accepted this revision.Feb 5 2018, 12:57 PM
This revision is now accepted and ready to land.Feb 5 2018, 12:57 PM
This revision was automatically updated to reflect the committed changes.